공지사항

Apache Log4j 2 보안 업데이트 권고
작성자 : 관리자작성일 : 2021-12-13 13:03:57조회 : 95

□ 개요
 o Apache 소프트웨어 재단은 자사의 Log4j 2에서 발생하는 취약점을 해결한 보안 업데이트 권고[1]
  o 공격자는 해당 취약점을 이용하여 악성코드 감염 등의 피해를 발생시킬수 있으므로, 최신 버전으로 업데이트 권고
 
□ 주요 내용
 o Apache Log4j 2*에서 발생하는 원격코드 실행 취약점(CVE-2021-44228)[2]
    * 프로그램 작성 중 로그를 남기기 위해 사용되는 자바 기반의 오픈소스 유틸리티

□ 영향을 받는 버전
 o Apache Log4j 2
    - 2.0-beta9 ~ 2.14.1 모든버전
 o Apache Log4j 2를 사용하는 제품
    ※ 참고 사이트 [4]를 확인하여 해당 제품을 이용 중일 경우, 해당 제조사의 권고에 따라 패치 또는 대응 방안 적용
 
□ 해결방안[1]
  o 제조사 홈페이지를 통해 최신버전(2.15.0)으로 업데이트 적용[3]
    ※ log4j 1.x버전 사용자의 경우 추가적인 업그레이드 지원 중지로 인해 다른 보안위협에 노출될 가능성이 높아 최신버전 업데이트 적용 권고

 o 최신버전으로 업데이트가 어려운 경우 사용중인 버전확인 후 버전별 조치 적용
  - (버전확인방법)
        1. log4j가 설치된 경로의 "pom.xml"파일을 열어 "log4j-core"로 검색

       2. 검색결과 "사용버전(version)" 확인가능
  - (조치방법) 2.0-beta9 ~ 2.10.0
       ※ JndiLookup 클래스를 경로에서 제거 : zip -q -d log4j-core-*.jar org/apache/logging/log4j/core/lookup/JndiLookup.class
   - (조치방법) 2.10 ~ 2.14.1
       ※ log4j2.formatMsgNoLookups 또는 LOG4J_FORMAT_MSG_NO_LOOKUPS 환경변수를 true로 설정


□ 기타 문의사항
 o 진료정보침해대응센터 02-6360-6500, 한국인터넷진흥원 사이버민원센터: 국번없이 118

 [참고사이트]
 [1] https://logging.apache.org/log4j/2.x/security.html
 [2] https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-44228
 [3] https://logging.apache.org/log4j/2.x/download.html
 [4] https://gist.github.com/SwitHak/b66db3a06c2955a9cb71a8718970c592

파일
TOP